Announcement:

Hello and welcome to Aquafadas Answers, the community forum for our digital publishing tools. Here you’ll find answers to common questions about our platform and software, as well as inspiration from fellow designers and developers.

Have a question or a great idea? Search the forum above or submit a new post!

By Matthieu Kopp
CTO
@aquaticmatt
0
Answered
David Johnson 2 years ago in Content Publication • updated by Hicham Tarhini 2 years ago 5

My app is live and I'm trying to update the Zave file, which is hosted on my server. I uploaded the new Zave to the server but when I launch the app it doesn't notify me of the update. Push notifications is on. Is there another step in the update process that I missed?

0
Fixed
Dear developer,
We have discovered one or more issues with your recent delivery for "ABAG Brazilian Yearbook of GA for iPhone". Your delivery was successful, but you may wish to correct the following issues in your next delivery:
Missing 64-bit support - Beginning on February 1, 2015 new iOS apps submitted to the App Store must include 64-bit support and be built with the iOS 8 SDK. Beginning June 1, 2015 app updates will also need to follow the same requirements. To enable 64-bit in your project, we recommend using the default Xcode build setting of “Standard architectures” to build a single binary with both 32-bit and 64-bit code.
After you’ve corrected the issues, you can use Xcode or Application Loader to upload a new binary to iTunes Connect.
Regards,
The App Store team
0
Fixed
Denny Denny Louis 1 year ago in Content Publication • updated by Kevin MARHIC (Support Tech) 1 year ago 6

Hi,


I am having some trouble in AppFactory iOS. I am trying to publish an iPhone app using the AVE Reader template, and when I go to place in the ZAVE file and AVE Certificate, the AVE Certificate (manifest.zavec) is not being accepted by the program (as shown in the image below).

For the record, I am using AppFactory iOS Version 4.2.3 (v9153), and have also tried using older versions, all versions have been giving me this error. Just to remind you, I am using the AVE Reader template in AppFactory.


The ZAVE I am using has been generated from the InDesign Authoring software for Mac, Version 3.7.1. I tried Version 4.0.0 of the InDesign Authoring software, but it caused a lot of bugs to my ZAVE file. I am using InDesign CC 2015.


And as far as I know I have followed every step in CloudConnect to set up the app correctly. The ZAVE has been uploaded to Dropbox, with the link ending in ?=dl1 . I also tried uploading the ZAVE to Amazon S3 to see if that made a difference, but it didnt.


The ZAVE file works perfectly when testing in the Aquafadas Viewer app.

I'm really not sure what to do from here, and I have a very short deadline to work to.


If I could please get some urgent help on this issue it would be very greatly appreciated.


Thanks

Denny

Answer

Hello again,


OK, so we finally managed to pinpoint what was happening. There is a bug that corrupts certificates by adding an empty line at the beginning of the files.


Here is a "workaround" for this issue:

  • Open the Zavec file in any text editor (TextEdit on Mac, Notepad on Windows should do the trick)
  • Delete the empty line you will find at the beginning of the file
  • Save your fixed zavec file
  • Add the zavec to your AppFactory project and you should be in the green

For now this should be enough and allow you to go forward and publish your apps. The problem on the certificate generation should be hotfixed on CloudConnect as soon as the reason this empty line appears is found. Until then, if your certificate fails in AppFactory, be sure to open it and remove that empty line!


Again, sincere apologies to everyone affected by this issue. In case you have trouble fixing your zavec file, do not hesitate to check back with us.


Best regards,

Kevin

Aquafadas Support

0
Answered
Hubert 2 years ago in Content Publication / AppFactory // Next Gen App • updated by Jerome [Aquafadas] 2 years ago 5

Hello, i have two new bugs on my computer :

1/ Since the update of Xcode to version 7.1, AppFactory is not able to launch anymore.

2/ Since the last update of AppFactory when i double click on my project, it opens the viewer installer instead of AppFactory.

Thanks.

H


0
Fixed
Marc Beckersjürgen 2 years ago in Content Publication • updated by Manu Brossard 10 months ago 6
The required format for both images is square (512x512 and 1024x1024), however, most magazine covers are not.
When submitting a PNG with a transparent background, the transparent area is rendered black in the kiosk frontend. Is this intended? How could we add a cover preview that is not square?



0
Under review
Ester Crisanti 2 years ago in Content Publication / AppFactory // Next Gen App • updated 2 years ago 7
Hello,
I have just created my Elegant Kiosk. I can see it on my ipad and ios simulator. The title already exist and I can see it in Cloud Connect.
Unfortunately I'm not able to load in my kiosk. So i I don't see the title in my kiosk (neither on my ipad neither on ios simulator).
Could you give me some advice to solve this problem?
Thanks
Ester Crisanti
0
Under review
Antoine 1 year ago in Content Publication / Cloud Connect • updated 1 year ago 3

Bonjour,


J'ai chargé une parution hier en batch processing sur cloud connect. Je ne la vois toujours pas sur notre application et plusieurs clients se plaignent également du problème.


Que dois-je faire pour corriger ce problème ?


Cordialement,

Antoine Mary

0
Answered
Willem 2 years ago in Content Publication / AppFactory // Next Gen App • updated by Manu Brossard 2 years ago 2
Bonjour , nous avons un problème avec le bundle ID de notre application . Actuellement le bundle ID est : com.mediacrossing.journalnumeriqued_aquitaine, seulement, apple n'accepte pas '_' dans les bundle ID, est il possible de renommer le bundle ID en : 'com.mediacrossing.journalnumeriquedaquitaine ?
0
Under review
Mark Turner 2 years ago in Content Publication • updated by anonymous 2 years ago 1
With the purchase of Single App document will I be able to fix any bugs or glitches within the 365 days of the purchase agreement?
0
Under review
Fabian Keller 2 years ago in Content Publication / AppFactory // Next Gen App • updated by anonymous 2 years ago 1
We discovered when we released our first iOS app on smartphones with the Swiss licencee of Aquafadas (iWare) that our iOS smartphone app scaled up from iOS Apps screen when loading the app. This means the Aquafadas app seems to have no retina optimization for iPhone 6 or 6 Plus (Retina).

How can we solve that it doesn't scale up the devices menu header (Provider, Wifi etc.) and stays in correct retina size? Or hasn't Aquafadas yet ported the app framework to do so?