Announcement:

Hello and welcome to Aquafadas Answers, the community forum for our digital publishing tools. Here you’ll find answers to common questions about our platform and software, as well as inspiration from fellow designers and developers.

Have a question or a great idea? Search the forum above or submit a new post!

By Matthieu Kopp
CTO
@aquaticmatt
+6
Answered

Apple Enterprise App

I have a new project and we will make it with Apple Enterprise Developer systems for distribution of in-house.

Are AppAppFactory applications (mono and kiosk) suitable for Apple Enterprise ?
How can we generate our apps for Apple Enterprise (ipa and plist file) ?
How can we set push notifications on them ?
How can we distribute them on the internet site?
How can we distribute them on MDM (Mobile Device Management system) ?
etc...

Can you help me ?

Thanks
Alp

+2
Answered

Device is setting up as test device but app factory is still not recognizing it

I have added the UUID of my device to the list of test devices on aquafadas, but I still get an error that the test device has not been added. Not sure where to go from here. Please advise if you have a possible solution.

Thanks!

+2
Answered

Does Aquafadas use IDFA

Cenveo 2 years ago in Content Publication / AppFactory // Next Gen App • updated by Arnaud Rossi (Head of Support) 2 months ago 2

During the process of load new app to Apple, we got a request for more information. Apple is asking if IDFA is used in the app. We said no, now it says it is in there how to resolve we are stuck


Below is an article

http://techcrunch.com/2014/02/03/apples-latest-crackdown-apps-pulling-the-advertising-identifier-but-not-showing-ads-are-being-rejected-from-app-store/

+1
Answered

"My Great Bookstore" template

Is this a new'ish template? Looks like it's only available for the iPad, will it ever work universally on the iPad and iPhone? Thanks!
0

http://www.supplementscart.com/juvenique/

Neem (a acclaimed detoxifying bulb in India which advances circulatory, abdomen related, respiratory and urinary wellbeing); adjudicator aciculate additive (decontaminates the blood, detoxifies the liver, and enhances the incontestable framework); Guduchi (a abating analeptic which supports the aggressive structure); Hari crop (a condoning laxative and expectorant), and apocryphal aphotic Juvenique (a age-old diuretic which helps processing and is about acclimated to accrue derma sound). Purim tablets accustomed in a   Juvenique -veggie lover alembic canteen and can be acquired online through the Himalaya Herbal Healthcare site, and added online acquaintance wellbeing stores. 

http://www.supplementscart.com/juvenique/


0
Not a bug

AppIcon.appiconset Error AppFactory Version 4.8.4 (v12992)

MDV 4 weeks ago in Content Publication / AppFactory // Next Gen App • updated by Arnaud Rossi (Head of Support) 2 weeks ago 2

Hey,

I use AppFactory Version 4.8.4 (v12992). 


If I try to compile a new Version for the iOS Simulator there is an error:

./AppIcon.appiconset/[][ios-marketing][][][][1x][2d][Icon-AppStore@2x.png]: warning: The app icon set "AppIcon" has an unassigned child.


Similar Error from Apple:

Missing required icon file - The bundle does not contain an app icon for iPhone / iPod Touch of exactly '120x120' pixels, in .png format for iOS versions >= 7.0.

Missing required icon file - The bundle does not contain an app icon for iPad of exactly '76x76' pixels, in .png format for iOS versions >= 7.0.

Missing required icon file - The bundle does not contain an app icon for iPad of exactly '167x167' pixels, in .png format for iOS versions supporting iPad Pro.

Missing required icon file - The bundle does not contain an app icon for iPad of exactly '152x152' pixels, in .png format for iOS versions >= 7.0.


AND


Missing App Store Icon - iOS Apps must include a 1024x1024px App Store Icon in PNG format. Without providing the icon in the Asset Catalog or via iTunes Connect, apps cannot be submitted for App Review or Beta App Review. Refer to https://developer.apple.com/ios/human-interface-guidelines/icons-and-images/app-icon/ for more information.


What should/can I do?

0
Answered

Where is the adjust-Framework?

aquafadas 3 months ago in Content Publication / AppFactory // Next Gen App • updated by Kevin MARHIC (Tech Support) 3 months ago 2

In the newest releases I can't find the adjust Framework anymore. It's important for us. When will this framework get back?

0
Declined

Does anyone know the reason for this message : this certificate does not authorize the creation of this kind of kiosk. You can’t create this application

adolfon7 3 months ago in Content Publication / AppFactory // Next Gen App • updated by Arnaud Rossi (Head of Support) 2 months ago 1

I downloaded a certificate for a NextGen App and I received this message:

this certificate does not authorize the creation of this kind of kiosk. You can’t create this application

0
Answered

Remote Reader (Universal)

Romain Duguet 7 months ago in Content Publication / AppFactory // Next Gen App • updated by Katherine (Support Tech) 6 months ago 5

Bonjour,


En choisissant le template mono-document pour iPad/iPhone [Remote Reader (Universal)], est-il possible de spécifier le zave téléchargé suivant le device ?


Exemple : lorsque j'installe mon application (app.ipa) sur iPhone, il va télécharger le contenu App-iPhone.zave. Et si j'installe cette même application sur iPad (app.ipa), le contenu téléchargé sera App-iPad.zave.


Merci pour votre réponse,


Romain

0
Answered

Application loader - ERROR ITMS-90534

Valentin 8 months ago in Content Publication / AppFactory // Next Gen App • updated by Jerome [Aquafadas] 8 months ago 4

Dear,


Since few days, Apple need to have XCode 8.3.2 to generate an app. So I've install it and generate a new IPA from App Factory but still have an error in the application loader (see error above) and can't send my app for validation. I don't know what to do ...


ERROR ITMS-90534: "Invalid Toolchain. New apps and app updates must be built with the public (GM) versions of Xcode 6 or later, macOS, and iOS SDK or later. Don't submit apps built with beta software including beta macOS builds."


WARNING ITMS-90703: "Deprecated Xcode Build. Due to resolved app archives issues, we will be deprecating Xcode 8.3 on May 10, 2017, at which time app archives built with 8.3 will no longer be accepted by the App Store. Download Xcode 8.3.2 or newer, rebuild your app and resubmit."


Thanks for your help

Valentin