Under review
Peter Sramek 8 months ago in Content Publication / Cloud Connect • updated 7 months ago 11

My new build works in AVE Preview and in Apple's Testflight as well as when exported directly to the device through Xcode.

The one oddity is that the Loading Screen flashes and the screen goes white during the downloading of the app files from the server.

Now when I have submitted it for review it is rejected by Apple with the following message. The screen shot says that it cannot find the app in the app store - which seems very odd. It says: "This product not available in the App Store". The only thing I can think of is that I changed the Aquafadas SKU to match the build number but I did leave the iOS SKU the same. Is this the problem?


Performance - 2.1

We discovered one or more bugs in your app when reviewed on iPad running iOS 10.2.1 on Wi-Fi connected to an IPv6 network.

We could not log in the app.

The steps to reproduce are:

1. Launched the app
2. The error message showed

There is a suggestion to be sure to test it with an IPv6 network - which is way beyond my ability to understand. All my testing checks out, except the final update submission.

I have tried to submit the application once more after recreating the product in Cloud Connect with the original SKU codes. I get the same result. It is saying that "This product is not available in the App Store".

The ipa file seems fine, works with iOS Test Flight, works on iPhones and iPads. I am stuck.

So - there is some progress - the error message went to: "The Action has failed" when Apple tried to test opening the app. It still runs fine in Test Flight on my iPad and on iPhones. Could it be that I have zaves configured for the various devices including iPad Pro and one of the versions does not work? Or that it is a problem of iOS 10.2.1 - which is what they are testing it on? I am not sure how to address that. It would be great to have some help.

Under review

The rejection because of incompatibility with IPv6 is often used by Apple's reviewers. We test our apps on IPv6 wifi networks and we where never able to reproduce the problem. So here is a message you can send them in response to this kind of rejection :

Here is a simple description of our test procedure.

#1 Our tests consist in putting us in the exact conditions described in Supporting IPv6 DNS64/NAT64 Networks
- We produce and app signed with an adHoc distribution profile.
- We perform a clean install (from scratch) on a device connected to the local network (NAT64).

> our apps launch correctly. We can do in-app purchases using the sandbox, download the purchased content and read.

#2 We could not reproduce the errors reported by the Apple Review team.

#3 We read thoroughly the Technical Q&A QA1764 but could not find any help in it as we seem to stick to every guideline.

#4 We found this post [https://forums.developer.apple.com/message/147579#147579] on your forum mentioning a discrepancy between the test protocol accessible to developers and largely described above, and the real tests run by the AppReview team. Unfortunately, we cannot put ourselves in the conditions of the AppReview team as we don’t know them. This article also describes some server side configurations that could lead to errors. We checked them all and we are on the safe side.

#5 Other apps using the same binary but accessing other content have been submitted and accepted.

I have resubmitted a build for Beta review and they have now rejected it because of a blank screen which appears during content download. I have prepared a response similar to yours for the IPv6 rejection, but I am not sure why AppFactory 4.7 is causing the disappearing loading screen. It appears for a second before going blank.

This is a Universal reader app. The screen does not disappear when I create a build with AppFactory 4.6.1.

I wonder if anyone else is having this problem.

Other than this, the app runs beautifully in Testflight. I am hesitant to resubmit before getting an opinion on teh disappearing Loading Screens.

II have the same issue: the loading screen disappear since the last update

I managed to reproduce this problem and reported it to the developers.

Peter, the product linking you single document app to its issue isn't free. That is why i get this when I test your app on my simulator :

The single document app can't make in-app purchases so it asks to register the device as test to bypass the purchasse process. This happens on the simulator but I think that on a real device the download would just fail.

I haven't had any problems downloading on multiple devices. As I said in the other ticket thread, I thought I had changed the product to a free one.

One problem I am having is that I cannot edit my product - I had to create a new one. When I select View or Edit of the product it just shows me the ID in a dialog box saying Update Product and the SKU, but doesn't allow me to do anything. Do I just delete it and create a new one?

I deleted the product and created a new one. This has corrected the format and made it a free one. The options were very clear this time.

Finally - all is well and the Update Build was accepted by Apple. Thanks for the help.

These idiosyncracies remain, but otherwise all is working:

The Loading Screen still goes blank while the app is downloading from the server.

Pinch zoom does not work for images expanded to fullscreen (which it does in the AVE Previewer app)

Audio does not auto play when you enter a page.