0
Under review
Ana Belén 4 weeks ago in Content Publication / AppFactory // Next Gen App • updated 4 weeks ago 9

Hello,

I have an app created with the Next Gen template with different content for several languages. I need to go from the main store model that has a default language to another store model that defaults to another language. I have tried to put in the main store model a component of store models linking with the store model q I am interested but does not show it because the language is different. I have also tried to put an HTML5 / Web component with a deeplinking but in the simulator the app is closed.

How can I do it?


Tanks in advance

Ana Belén

Under review

Hello Ana Belén,


Could you send us your cloud connect account ID as private message please?


Thanks

Katherine

Aquafadas support

I already sent it to you

Thanks

Ok, I've got it. So you want to go from your main store model 'homeesp1' that is in Spanish to which store model?


Thanks,

Katherine

I want to go "homeeng1" that is in English and vice versa

Hello


I've tested your app and it seems to work with the first option in Main store model 'homeesp1'. So you can keep the first component and delete the html 5.

Please also update the tools, Indesign Authoring 4.6 and AppFactory 4.7.2


Then generate your app again and send me your feedback.

GrupoAsis.png


Thanks,

Katherine

Aquafadas Support

Hello,


I had already updated the AppFactory to version 4.7.2 and InDesign Authoring I installed it although I do not use it. I have re-exported the app to iOS simulator and the result is still the same, it does not load the English model store. Android does not load the English model store.

What could be happening?


Thanks

Ana Belén

Hello,


I am doing tests and when I change the device language to English in the simulator it does not even show me the main store model.

In android is happening the same thing and also the main menu is not working correctly. If I enter the "settings" or "Website" options then there is no way to go back.
Please I need an urgent solution to these problems, today I have to present the app and as it stands it is unpresentable.

Thanks

Ana Belén

Hello Ana Belén,


I tested the store models in another app, and the use of languages worked fine.

Please check this page and you will find all the necessary info about the store models and localization languages (there's an option to show the available languages)


https://www.aquafadas.com/documentation/calenco/en/Build_a_Next_Gen/content/ch03s03.html


Hope this can help you.

Kind regards,

Katherine

Aquafadas support

Hello,

That information that you show me I have been checking several times and I see that the store models I created are correct or I do not see if there is an error.

I need help.

Thanks

Ana Belén